1
0
Fork 0
forked from mirror/cinny
cinny/flake.nix

23 lines
709 B
Nix

{
description = "A very basic flake";
inputs.nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
inputs.flake-utils.url = "github:numtide/flake-utils";
outputs = { self, nixpkgs, flake-utils }:
flake-utils.lib.eachDefaultSystem (system: let
pkgs = import nixpkgs { inherit system; };
cinny = pkgs.buildNpmPackage {
name = "cinny";
src = ./.;
npmDepsHash = "sha256-43nCceq1hR89m/xvC+89qxHGdtOUKjZU/MAz4pYu8K0=";
nativeBuildInputs = with pkgs; [ python3 pkg-config ];
buildInputs = with pkgs; [ pixman cairo pango ];
installPhase = ''
cp -r dist $out
'';
};
in {
packages.default = cinny;
});
}